Services Status

All systems are operational.

Affected Components

Affected Components: GroundLink App

Fixed

1 week ago

GroundLink App recovered. All configured checks are passing again.

Investigating

1 week ago

GroundLink / GroundLink App is reporting Major Outage.

Reported

1 week ago

GroundLink App recovered. All configured checks are passing again.